Running WoW with Whisky on MacOS 14.2.1

Post and discuss all your Mac & Linux related issues and how to fix them here.
Forum rules
This forum is STRICTLY for Mac & Linux issues!
No Windows or other operating-system issues!
Post Reply
Posts: 1
Joined: Mon Feb 12, 2024 12:24 pm

Running WoW with Whisky on MacOS 14.2.1

Post by Esto » Tue Feb 13, 2024 11:31 am

Hi there.

I'm currently trying to set up one of my macs with the launcher from wow-mania.
Unfortunately I can't install wine because I'm on a Mac Mini M1 with MacOS 14.2.1 Sonoma - so I have to use Whisky for further wine support on this M1 CPU.

Download and setting up Whisky worked fine but the Launcher won't start. Only the wow-mania.exe works but crashes every time when I want to login to the realm. I guess thats why I could get the patches from the launcher since I loaded the torrent and no further patches.

Does anybody had the same issue / constellation of hardware and worked this out? I'd tried to start launcher as Administrator but I don't know how to start as admin in Whisky.

Is there any other option to get this game to work on a M1 Mac?

Thanks in advance for any help :D

Posts: 1
Joined: Thu Feb 22, 2024 12:42 pm

Re: Running WoW with Whisky on MacOS 14.2.1

Post by angleter » Thu Feb 22, 2024 1:08 pm

you can try CrossOver app, mine works fine with minimum settings.

Posts: 3
Joined: Tue Oct 29, 2019 1:25 pm

Re: Running WoW with Whisky on MacOS 14.2.1

Post by SHUTDOWN96 » Wed Apr 10, 2024 2:11 pm

I managed to achieve that, by:
1. Creating a bottle with Windows XP
2. Installing d3dx9 winetrick.

Launcher and game itself are starting, but I encoiuntered an error I described here: ... 3568#p3568

Post Reply