General Support

Error stopping travel to Northrend [SOLVED]

Need support regarding: Connecting issues, launcher issues, website issues or client bugs? Make a thread in here and our staff will be with you shortly.
Forum rules

Error stopping travel to Northrend [SOLVED]

Postby londoner » Mon May 13, 2019 5:51 pm

Has anyone come across the following error when trying to get to Northrend?

When I leave from Stormwind Port (I have not tried Menethil Harbour), on the boat for Northrend, just after the boat leaves I get teleported to the Westfall/Longshore graveyard with the error: "You must have The Wrath of the Lich King expansion installed to access this area".

It sounds like a simple problem, doesn't it - except I am using client 3.3.5 (downloaded from the torrent link on the wow-mania website), and I have the up to date launcher. The WoW loading screen says: ver 3.3.5 (12340) (wow-mania 2.5.5).

I know the expansion is the one I am using because I can see the DK starting area floating above Lights Hope Chapel and I can see Northrend on the map.

Interestingly I cannot create a DK character - in any faction or race combination.

I am currently level 64 and working my way through Outland - so its not an urgent problem, but I don't want to get to 70+ and still not be able to get to the fun stuff. My google-fu only turned up one similar issue, but with no conclusive resolution.

So, if any of my fellow players had this/solved this, I would love to hear. Or if a GM would like to investigate, even better.

Posts: 1
Joined: Mon May 13, 2019 5:40 pm

Re: Error stopping travel to Northrend

Postby Aymelek » Tue May 14, 2019 7:15 am

Hello there

When you created your account you selected TBC expansion.
Open a ticket in-game and me or another GM will upgrade you WoTLK expansion.

See you in game
Game Master Aymelek - Discord: Aymelek#0977

Discord: Janitor#2871

Website & Social Media
YouTube: WoW-Mania Private Server Ltd
User avatar
Game Master
Posts: 208
Joined: Thu Mar 08, 2018 6:10 pm

Return to Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests