Forums - Guide on Resolving Patch Issues

  • Author
    Posts
  • #6621
    •      
     
    avatar

    Chang
    Members
    Posts: 113
    Joined: 12/31/15
    Upvoted: 5

    We should all be familiar with the latest patch by now, and that it has caused many errors and bugs for some. I'm here to provide you with a small guide to get this patch to work. There may still be bugs and errors, but those are for everyone. This guide is intended for getting your client up to date. Any other issues will get resolved ASAP.

    To get started, you need the WoW-Mania client. Head to our download page to download it if you don't have it. When that's done, download our updated launcher which can be found on our download page aswell. Once you've finished downloading the launcher, you need to extract the folder it's in and place all of the files from that folder in your WoW-Mania folder. About 8 files will have to be overwritten. Make sure you click yes when it asks you if you want to overwrite them. You now have the updated launcher. Before you use the launcher, make sure you've unchecked 'Read Only' in your folder properties. This can be done by heading outside of your WoW-Mania folder, right clicking that folder, clicking 'Properties', unchecking 'Read Only' in the 'General' tab, and confirming the change.

     

    I suggest reading the next 'EXTRA' steps and following them. These may solve some issues that you might still be experiencing.

     

    EXTRA (1): Delete the patches A, B, and W, from your enGB folder. These can be found in your WoW-Mania folder. From there, head into your Data folder, there you should see the enGB folder, open it and right click the mentioned patches and remove these one by one. Download these back by using the launcher.

    EXTRA (2): If you wish to play without the WoD textures (which is an option that can be unchecked when using the launcher) and the option does not work for you, change the names of the following patch files like so:

    1: (Data folder): patch-W.MPQ => patch-W._MPQ

    2: (enGB folder) patch-enGB-B.MPQ => patch-enGB-B._MPQ

    3: (enGB folder) patch-enGB-W.MPQ => patch-enGB-W._MPQ 

    As mentioned before, these folders (the Data and the enGB folder) can be found in your WoW-Mania folder. From there you can go into your Data folder to adjust the name of the first patch file, after that you can head into your enGB folder to adjust the names of the other mentioned patch files.

    EXTRA (3): If you are unable to connect to our servers you may want to disable your Firewall or/and anything else that may be blocking you from connecting with our servers. After you do that, restart your game and try to connect again!

    EXTRA (4): Download THIS. Then run the installer (you may already have this installed. In that case abort the installation and skip this 'EXTRA' step, you'll be notified if it's already installed).

    After you finished installing, rename your 'WoW-Mania - Win' folder to 'WoW-Mania'.

    Then restart the device that you play on, and enter the game.

    EXTRA (5): You may also want to try to run your game as an administrator, right click your launcher and click 'Run as administrator' to do this.

     

     

    If you've any issues related to this patch after having given my guide a try, I suggest redownloading the WoW-Mania client and trying again. If you then still experience issues related to this patch, open an in-game ticket and wait for a Gamemaster to help you. If you can't connect to our servers, I suggest adding, and contacting wow-mania.com on Skype. 


    To see if the patch works, log into the game and head to the character creation screen. Check out the new races, the Goblin and the Worgen. If the Worgen looks like Fel Orc, your patch isn't working correctly (if you've disabled the WoD textures you can't see the new races in-game, I suggest you enable them and take a minute of your time to see if the patch works for you. After that you can always disable them again if you prefer playing without the WoD textures).


    Upvoted by: Jumpido, Delroy, Tanksalot, Xenia, Alitoni

    #6623
    •      
     
    avatar

    Jumpido
    Members
    Posts: 1
    Joined: 1/31/16
    Upvoted: 0

    This worked for me!

    Thanks Chang! :)



    #6657
    •      
     
    avatar

    Excesse
    Members
    Posts: 11
    Joined: 6/13/15
    Upvoted: 0

    I downloaded the launcher again to see if the launcher was the problem and removed patches and now my launcher wont download any patches... how do I solve this?



    #6678
    •      
     
    avatar

    Tanksalot
    Members
    Posts: 161
    Joined: 12/29/15
    Upvoted: 0

    Excesse wrote on February 10, 2016

    I downloaded the launcher again to see if the launcher was the problem and removed patches and now my launcher wont download any patches... how do I solve this?

    Hello there!

     

    try these:

    1: check if your wow-mania folder is not "read-only", by clicking with right mouse button > properties > and untick the "read-only box.

    2: run the launcher as administrator, by clicking it with right mouse button > "launch as administrator".

     

    Hope this helps



    #6685
    •      
     
    avatar

    eugenajazaj
    Members
    Posts: 6
    Joined: 1/13/16
    Upvoted: 0

    Chang thanks a lot , that post really helped me to get into the game , i appreciate it you did a really good job. 

    <3 you mate :D



    #6688
    •      
     
    avatar

    Chang
    Members
    Posts: 113
    Joined: 12/31/15
    Upvoted: 0

    Excesse,

     

    As said in the last few lines of my guide: "IF YOU'VE ANY ISSUES RELATED TO THIS PATCH AFTER HAVING GIVEN MY GUIDE A TRY, I SUGGEST REDOWNLOADING THE WOW-MANIA CLIENT AND TRYING AGAIN. IF YOU THEN STILL EXPERIENCE ISSUES RELATED TO THIS PATCH, OPEN AN IN-GAME TICKET AND WAIT FOR A GAMEMASTER TO HELP YOU. IF YOU CAN'T CONNECT TO OUR SERVERS, I SUGGEST ADDING, AND CONTACTING WOW-MANIA.COM ON SKYPE.".



    #6760
    •      
     
    avatar

    Xenia
    Members
    Posts: 1
    Joined: 12/20/15
    Upvoted: 0

    good ty



    #6874
    •      
     
    avatar

    PandaPants
    Members
    Posts: 2
    Joined: 2/14/16
    Upvoted: 0

    Works.



    #6897
    •      
     
    avatar

    Excesse
    Members
    Posts: 11
    Joined: 6/13/15
    Upvoted: 0

    DalaiLamer wrote on February 11, 2016

    Excesse wrote on February 10, 2016

    I downloaded the launcher again to see if the launcher was the problem and removed patches and now my launcher wont download any patches... how do I solve this?

    Hello there!

     

    try these:

    1: check if your wow-mania folder is not "read-only", by clicking with right mouse button > properties > and untick the "read-only box.

    2: run the launcher as administrator, by clicking it with right mouse button > "launch as administrator".

     

    Hope this helps

    The read only thing is an issue I resolved several months ago when I started using the launcher so I always check that, and launch as admin didnt do the trick either unfortunately.

    I am reinstalling everything atm still waiting for results



    #6904
    •      
     
    avatar

    Excesse
    Members
    Posts: 11
    Joined: 6/13/15
    Upvoted: 0

    Ok didnt even help to reinstall the windowsverision..... Now it just said "Interface files are corrupt please reinstall the game" like I already didnt do that lol



    #6986
    •      
     
    avatar

    Prium
    Members
    Posts: 53
    Joined: 8/18/15
    Upvoted: 0

    but but... Ptach B is so amazing... D; it makes everything so freaken amazing! :OOO


    Emperor of "The Legion"


    #7045
    •      
     
    avatar

    Ekosophos
    Members
    Posts: 1
    Joined: 1/7/16
    Upvoted: 0

    Excesse wrote on February 15, 2016

    Ok didnt even help to reinstall the windowsverision..... Now it just said "Interface files are corrupt please reinstall the game" like I already didnt do that lol

    I got the same message, i redownloaded and it worked.



    #7439
    •      
     
    avatar

    Filer169
    Members
    Posts: 7
    Joined: 1/18/16
    Upvoted: 0

    I have problem, when I open Launcher.exe it shows the launcher but it's not updating or anything. I have a screenshot for that http://screenshooter.net/101986592/oyvmnrx . Anyone know how to solve this problem?



    #7508
    •      
     
    avatar

    Kuurator
    Members
    Posts: 17
    Joined: 7/1/15
    Upvoted: 0

    Chang,

    Thank you for the post, and the link to the post.

    I had some issues running without WoD textures, and extra #2 did not work for me. Here is what did work.

    I did a clean torrent install, and then changed folder permissions. I changed permissions by going into the folder properties tab and then the securities tab.

    In general I followed the directions to setup the game outlined here:

    http://www.wow-mania.com/connect

    At this point, a clean folder had been downloaded. The game ran fine with WoD textures. But I found that unchecking the WoD texture box from the launcher did not work for me. The information in extra #2 did not work for me. I tried a number of things actually.

    What did work was the following: Remove the A and B patches from the Data\enGB folder, and then refrain from using the launcher. The launcher will only replace the files you just removed and you will be back where you started.

    Instead use "wow.exe" and the game will run with the old textures.



    #7625
    •      
     
    avatar

    Thuralion
    Members
    Posts: 1
    Joined: 3/12/16
    Upvoted: 0

    Excesse wrote on February 15, 2016

    Ok didnt even help to reinstall the windowsverision..... Now it just said "Interface files are corrupt please reinstall the game" like I already didnt do that lol

    I got it too ....... I got it too .... after several times of the complete purge & download I get this error :/



    #10299
    •      
     
    avatar

    Insight
    Members
    Posts: 1
    Joined: 9/3/16
    Upvoted: 0

    Thanks! This solved my issue as well!



    #10465
    •      
     
    avatar

    SlyFox82
    Members
    Posts: 1
    Joined: 12/6/16
    Upvoted: 0

    Kuurator wrote on March 8, 2016

    Chang,

    Thank you for the post, and the link to the post.

    I had some issues running without WoD textures, and extra #2 did not work for me. Here is what did work.

    I did a clean torrent install, and then changed folder permissions. I changed permissions by going into the folder properties tab and then the securities tab.

    In general I followed the directions to setup the game outlined here:

    http://www.wow-mania.com/connect

    At this point, a clean folder had been downloaded. The game ran fine with WoD textures. But I found that unchecking the WoD texture box from the launcher did not work for me. The information in extra #2 did not work for me. I tried a number of things actually.

    What did work was the following: Remove the A and B patches from the Data\enGB folder, and then refrain from using the launcher. The launcher will only replace the files you just removed and you will be back where you started.

    Instead use "wow.exe" and the game will run with the old textures.

     

    I've tried this myself, after being told by a GM to reinstall the game, but not exactly telling me how to do this :( My Blood Elf NPC's faces are still screwed up.... I've gone through everything in the step list, and nothing worked, i followed what this guy did, and still nothing :( wtf is this?!?!??!