General Support

Bought VIP, extreme lag and disconnects

Need support regarding: Connecting issues, launcher issues, website issues or client bugs? Make a thread in here and our staff will be with you shortly.
Forum rules
NOT FOR IN-GAME SUPPORT.

Bought VIP, extreme lag and disconnects

Postby Kizbit » Wed Nov 29, 2017 7:53 pm

I just purchased VIP yesterday, and I'm not sure if the two are connected, but I am experiencing extreme lag and frequent disconnects. The game is pretty much unplayable at this point because I log in, move a few steps forward, try to take an action like mounting, but it takes an entire minute, and then I disconnect.

This happens to various degrees of success, sometimes I can play for ten minutes, but then I lag out and disconnect. I post in chat about lag, but no one else seems to be experiencing it. Not sure how to fix it. Any help is greatly appreciated.
Kizbit
 
Posts: 3
Joined: Wed Nov 22, 2017 1:21 am

Re: Bought VIP, extreme lag and disconnects

Postby Janitor » Wed Nov 29, 2017 8:14 pm

The two has absolutely no connection.
Check your connection quality and add-ons. Disable all add-ons as a first check.

If the issue continues contact me on skype or email and we can try to sort it.
Architect of Disruption since 1995
User avatar
Janitor
Owner
 
Posts: 348
Joined: Sun Sep 18, 2016 2:02 pm
Location: Azeroth

Re: Bought VIP, extreme lag and disconnects

Postby Kizbit » Wed Nov 29, 2017 8:59 pm

Thank you, I am not using any addons whatsoever.
Kizbit
 
Posts: 3
Joined: Wed Nov 22, 2017 1:21 am


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests